Node Toolbars

Video Transcript

The node toolbar section organizes node definitions into several tabs. To create an instance of a node definition, simply drag it from the toolbar to a Node Screen Editor. Note that you can also add nodes by right clicking on a Node Screen Editor and selecting a node type from the menu.

The built in nodes are organized into several tabs. First is the IO tab, meaning Input and Output. These are nodes that do a digital or analog read or write to a physical pin. The Activations tab has nodes that have to do with modifying an Activation value. The Flow Control tab has nodes that are used for designing logic and the flow of activation values through a program. The Math tab has nodes used to work with integer values.

Most data in an Embrio program is dealt with using the Activation data type, which is a floating point number between 0 and 1, so nodes on the Math tab are not often used. The Text tab has nodes used to deal with text data.

The Project tab is a place where you can add your own node definitions to be saved with a project. Nodes that you add to other tabs are available to all of your projects, nodes in the Project tab are only available to the Project they are added to. The Image tab has nodes for dealing with image data. These nodes cannot be used on an Arduino project, they can only be used on a PC project type.

The last tab is the Library. This library is maintained on the Embrio web site and has nodes that interact with certain pieces of hardware, as well as additional logic nodes. You can also see the library at Embrio.io/library to see more information about using these nodes.

View discussion page on forum